ampage
Tube Amps / Music Electronics
For current discussions, please visit Music Electronics Forum. New: visit Schematic Hell!
 
The sunn still shines online!

 :
Listen to great tunes streaming live right now!

ampage archive

Vintage threads from the first ten years

Search for:  Mode:  
previous: pete Hi everyone,Ok so t... -- 1123904687 View Thread

Re: hot tubes, I mean really hot

8/13/2005 1:48 AM
Mark Black
Re: hot tubes, I mean really hot
Have you replaced those bias filter caps yet? If not they may now be leaky since electrolytics REALLY hate reverse polarity usage even for a little while, and that could still be dragging down the voltage.  
 
I wouldn't even put power tubes in and try to bias until you can get -42V or preferably better at the high end (or with negative voltage would that be low end?) of the bias range with tubes out.  
 
Probably a good time to double/triple check the hookup and values of all of the resistors & other components in the bias circuit.  
 
If the caps are replaced and all component connections are verified but there are still problems maybe you could take some AC and DC measurements at various nodes and list them here. Starting at the anode of the bias rectifier and at other points working farther along towards the power tube control grid pins would probably work.  
 
Hopefully you'll soon be in tone bliss after finally getting this bias thing worked out...  
 
-Mark

 
Replies:
pete Yeah I swapped the electrolytics, a... -- 8/13/2005 8:44 PM